Results 1 to 15 of 15

Thread: Dead JX JB200 Fail

  1. #1
    Join Date
    Oct 2009
    Location
    Some where in the Caribbean
    Posts
    2,204
    Satfix Buxs
    77,196
    Thanks
    2,783
    Thanked 1,115x in 481 Posts
    Items Vintage truck
Gift received at 12-16-2012, 02:10 PM from hope32Crown Royal
Gift received at 12-15-2012, 10:31 PM from ICEMAN
Message: merry christmas amigo..and thank youWhiskey
Gift received at 10-01-2012, 03:33 PM from clarkBENT

    Default Dead JX JB200 Fail

    Hello gang, my friend has a JX V4 I think, he has both tuner one DVB S2 and one JB200 Plus, today he was watching TV and receiver died, red led blinking, I went to check and the receiver came to life after I removed the JB200 tuner, to be sure I removed the DVB also tried the JB200 on both Slots and every time I turn on the rear switch the red led blinks, I removed again the JB200 tuner and receiver works fine.
    Is there a way to fix this problem or its better to get another JB200 Tuner? Thanks in advance IPTVKid.

  2. #2
    Join Date
    Dec 2012
    Posts
    1,366
    Satfix Buxs
    7,987
    Thanks
    9
    Thanked 1,522x in 764 Posts

    Default

    If you read a little you should find that the turbo modules on many boxes tend to fail. Usually an issue with overheating.

  3. The Following 2 Users Say Thank You to jvvh5897 For This Useful Post:


  4. #3
    Join Date
    Oct 2009
    Location
    Some where in the Caribbean
    Posts
    2,204
    Satfix Buxs
    77,196
    Thanks
    2,783
    Thanked 1,115x in 481 Posts
    Items Vintage truck
Gift received at 12-16-2012, 02:10 PM from hope32Crown Royal
Gift received at 12-15-2012, 10:31 PM from ICEMAN
Message: merry christmas amigo..and thank youWhiskey
Gift received at 10-01-2012, 03:33 PM from clarkBENT

    Default

    The JX has 2 12Volts fans with external power supply, the Receiver never heats up with those 2 fans, 1 is amied at the tuner the other to heat disipator in thw main board, that is why I am asking because this receiver has no heating problems..............when a JB200 fails because of heat the receiver gives you a No Signal message, this receiver just went off with red light blinking.
    Can replacing the 2 caps shown in an old thread fix this problem?
    Last edited by IPTVKid; 08-23-2017 at 07:19 PM.

  5. #4
    Join Date
    Dec 2012
    Posts
    1,366
    Satfix Buxs
    7,987
    Thanks
    9
    Thanked 1,522x in 764 Posts

    Default

    You can certainly try it. Most folks just buy a new module because they are cheap to buy. Course most folks don't bother to solder or buy parts or post pin-outs or much of anything too tech these days.

  6. #5
    Join Date
    Mar 2015
    Location
    turks and caicos
    Posts
    63
    Satfix Buxs
    255
    Thanks
    529
    Thanked 51x in 25 Posts

    Default

    Hi I tried solder new diodes on jb200.Didn't work .I have 5 dead jb200.

  7. #6
    Join Date
    Oct 2009
    Location
    Some where in the Caribbean
    Posts
    2,204
    Satfix Buxs
    77,196
    Thanks
    2,783
    Thanked 1,115x in 481 Posts
    Items Vintage truck
Gift received at 12-16-2012, 02:10 PM from hope32Crown Royal
Gift received at 12-15-2012, 10:31 PM from ICEMAN
Message: merry christmas amigo..and thank youWhiskey
Gift received at 10-01-2012, 03:33 PM from clarkBENT

    Default

    Quote Originally Posted by schylla View Post
    Hi I tried solder new diodes on jb200.Didn't work .I have 5 dead jb200.
    The thing is the JB200 you know when they are about to die because with no reason they start loosing signal, you reboot the receiver and works again for a few minutes and back again to no signal unless you install a fan, but the problem here is the receiver was working and suddenly turned OFF by it self, he tried reboot but nothing, just red light flashing, it looked that the receiver died, but after removing the JB200 the receiver Boots and works, I tried the JB200 with 2 different JynxBox with same results, the receiver doesn't boot only red light blinks poorly.
    Since my hands shake a lot I asked a friend that works with electronic to solder the caps shown in an old photo, now the JB200 is back to life, I will see how long this fix last.
    jb200 improve solution 1_zpsm6qtsttz.jpg
    Last edited by IPTVKid; 08-25-2017 at 10:42 PM.

  8. #7
    Join Date
    Sep 2012
    Location
    in the dog house
    Posts
    2,924
    Satfix Buxs
    313,612
    Thanks
    4,142
    Thanked 5,989x in 1,911 Posts
    Items G&R
Gift received at 11-06-2012, 02:51 AM from Styx_N_Stones
Message: Merry Christmas and Happy Birthday,

     I noticed your signature was looking a little bare, so here's a little something to help you decorate it.

Happy Holidays,
S_N_SImmunity to Theft
Gift received at 07-25-2011, 12:29 AM from ICEMAN
Message: merry chritmas

    Default

    Quote Originally Posted by IPTVKid View Post
    The thing is the JB200 you know when they are about to die because with no reason they start loosing signal, you reboot the receiver and works again for a few minutes and back again to no signal unless you install a fan, but the problem here is the receiver was working and suddenly turned OFF by it self, he tried reboot but nothing, just red light flashing, it looked that the receiver died, but after removing the JB200 the receiver Boots and works, I tried the JB200 with 2 different JynxBox with same results, the receiver doesn't boot only red light blinks poorly.
    Since my hands shake a lot I asked a friend that works with electronic to solder the caps shown in an old photo, now the JB200 is back to life, I will see how long this fix last.
    jb200 improve solution 1_zpsm6qtsttz.jpg
    It should last just as long as a new one would, I have never had one to go bad but on the other hand I do use an old DN receiver to power the LNB and extra fans in the receiver to keep it cool.
    Last edited by iq180; 08-26-2017 at 01:05 AM.

  9. The Following User Says Thank You to iq180 For This Useful Post:


  10. #8
    Join Date
    Oct 2009
    Location
    Some where in the Caribbean
    Posts
    2,204
    Satfix Buxs
    77,196
    Thanks
    2,783
    Thanked 1,115x in 481 Posts
    Items Vintage truck
Gift received at 12-16-2012, 02:10 PM from hope32Crown Royal
Gift received at 12-15-2012, 10:31 PM from ICEMAN
Message: merry christmas amigo..and thank youWhiskey
Gift received at 10-01-2012, 03:33 PM from clarkBENT

    Default

    Quote Originally Posted by iq180 View Post
    It should last just as long as a new one would, I have never had one to go bad but on the other hand I do use an ond DN receiver to power the LNB and extra fans in the receiver to keep it cool.
    That detail is what made me more curious about this JB200, the receiver has 2 fans, both fans have their own power supply so it doesn't drain the receiver's power, another thing, this JB200 is the Plus, the ones found on JynxBox V5+, V4+ and V6, with the specs of 650 miliamps for LNB Control......

  11. #9
    Join Date
    Dec 2018
    Posts
    13
    Satfix Buxs
    2,274
    Thanks
    2
    Thanked 3x in 3 Posts

    Default

    Quote Originally Posted by IPTVKid View Post
    That detail is what made me more curious about this JB200, the receiver has 2 fans, both fans have their own power supply so it doesn't drain the receiver's power, another thing, this JB200 is the Plus, the ones found on JynxBox V5+, V4+ and V6, with the specs of 650 miliamps for LNB Control......
    Yes old post, when you posted this on SatFix aka satellite fix, as iptvkid, I found that funny. was it just me?
    Also did you figure out the problem?

  12. #10
    Join Date
    Oct 2009
    Location
    Some where in the Caribbean
    Posts
    2,204
    Satfix Buxs
    77,196
    Thanks
    2,783
    Thanked 1,115x in 481 Posts
    Items Vintage truck
Gift received at 12-16-2012, 02:10 PM from hope32Crown Royal
Gift received at 12-15-2012, 10:31 PM from ICEMAN
Message: merry christmas amigo..and thank youWhiskey
Gift received at 10-01-2012, 03:33 PM from clarkBENT

    Default

    New caps did the work.....on the JB200
    Testing: FreeSat GTC, KI PRO, MEELO+one PRO, Cloud I Box II, FreeSat V7Plus, GLOBO HD405
    SATS: 58w, 40.5, 30 and 70w
    There is no way to Peace, Peace is the way. Author: A.J. Muste
    There are no stupid questions, only stupids that don't ask....

  13. The Following User Says Thank You to IPTVKid For This Useful Post:


  14. #11
    Join Date
    Oct 2012
    Posts
    88
    Satfix Buxs
    742
    Thanks
    76
    Thanked 45x in 29 Posts

    Default

    I am very happy I saw this post as I am having a similar problem, My Jynxbox V3 running with a 12V fan that is externally powered and only connected to two sats 110 & 119 with a diseqc switch, the JB200 when installed in both slots it cause the receiver to keep rebooting and when I remove it the receiver works fine. So I am now convinced that the JB200 is just a poorly built part and is affected by not only over heating but also built with inferior parts. Mine has stopped working and it was always running with a fan so cooling down the board is not the only solution as the Caps in these things are just crap. Will be changing out these caps with the 22uf 25 volts ones and see what happens.

  15. #12
    Join Date
    Apr 2017
    Posts
    66
    Satfix Buxs
    216
    Thanks
    4
    Thanked 22x in 17 Posts

    Default

    Unplugging the receiver when not in use has kept me from
    Buying hd module every year

  16. #13
    Join Date
    Jan 2013
    Posts
    408
    Satfix Buxs
    1,011,087
    Thanks
    275
    Thanked 214x in 94 Posts
    Items Cake
Gift received at 01-17-2020, 06:23 PM from orchidgirl
Message: Just because...DeeVintage car
Gift received at 01-12-2020, 02:48 AM from orchidgirlSome beer
Gift received at 01-08-2020, 05:13 PM from orchidgirlYacht
Gift received at 01-08-2020, 02:11 AM from orchidgirlTractor
Gift received at 12-30-2019, 11:42 PM from orchidgirlCanadaDogDevil

    Default

    Quote Originally Posted by schylla View Post
    Hi I tried solder new diodes on jb200.Didn't work .I have 5 dead jb200.
    I did one last week. Working perfectly now. That's at least a dozen I've done over the years. Seems some of these boards go no matter what you do, but I can tell you they last a lot longer with the new diodes. Sorry, I mean new capacitors.
    Last edited by Newfygarge; 12-23-2019 at 02:50 PM.

  17. #14
    Join Date
    Oct 2012
    Posts
    88
    Satfix Buxs
    742
    Thanks
    76
    Thanked 45x in 29 Posts

    Default

    Quote Originally Posted by Newfygarge View Post
    I did one last week. Working perfectly now. That's at least a dozen I've done over the years. Seems some of these boards go no matter what you do, but I can tell you they last a lot longer with the new diodes.
    Do you mean capacitors or diodes?

  18. #15
    Join Date
    Oct 2012
    Posts
    88
    Satfix Buxs
    742
    Thanks
    76
    Thanked 45x in 29 Posts

    Default

    I can say that I have been very lucky then because this is my 1st problem with the JB200 in my box after a few years, I am sure mine is over 3 years so I can count my lucky stars. But as I said I had it running with a fan so maybe why it lasted so long. It still is working except for the rebooting issue.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •